Problem with pageimage and bookmarks

Having problems with DHTML Menu? There is usually somebody here who knows the answer.
Post Reply
Ralls
Advanced
Advanced
Posts: 16
Joined: Wed Jan 24, 2007 9:37 am

Problem with pageimage and bookmarks

Post by Ralls » Fri Oct 26, 2007 11:24 am

One section of my main menu links to a single page that has multiple bookmarks on that page. When I link to a bookmark, the double arrow pageimage correctly shows in front of the bookmark link on the menu. However, if I then link to another (or any subsequent) bookmark on the same page, the pageimage does not move to the new bookmark link on the menu. Can the menu be configured so the pageimage moves with bookmark links on the same page like it moves for links between pages? Any help greatly appreciated.

User avatar
Ruth
 Team
 Team
Posts: 8761
Joined: Thu May 15, 2003 5:02 am
Location: Yucaipa, CA
Contact:

Re: Problem with pageimage and bookmarks

Post by Ruth » Fri Oct 26, 2007 5:32 pm

Hi,

We need a url. Thanks

Ruth

Ralls
Advanced
Advanced
Posts: 16
Joined: Wed Jan 24, 2007 9:37 am

Re: Problem with pageimage and bookmarks

Post by Ralls » Fri Oct 26, 2007 11:09 pm

I can't provide a link at the moment, but here is a screenshot of your site from which I can demonstrate the problem. I'll try to be a little more specific:

Image

First, imagine that all the links shown are bookmark links on the same html page. If I were to click the first link, "Product Pricing &Purchasing" the double red arrow would correctly show in front of that text (just like on the screenshot).

Here's where the problem comes in. If I click a second (or third, etc.) link on that same page, for example the "Tooltips" link, then the red double arrow stays with the initial link, "Product Pricing &Purchasing," and does not display in front of "Tooltips."

This only happens when the links are on the same page and accessed by a "page.html#target" type link. Otherwise, the double red arrow positions itself correctly.

I tried using the full url and a few combinations thereof and that didn't have any effect. Hope you can help.

User avatar
Ruth
 Team
 Team
Posts: 8761
Joined: Thu May 15, 2003 5:02 am
Location: Yucaipa, CA
Contact:

Re: Problem with pageimage and bookmarks

Post by Ruth » Sat Oct 27, 2007 2:31 am

Hi,

OK, now I understand what you mean. Page highlighting will not work on anchor links. The reason is that you are on the same page, therefore the menu thinks it has made the match. If the page were to refresh when you clicked the next anchor then you could do the page highlighting.

There is a 'sort of' thing you could do, you could use something like clickcolor=. This means that when you clicked on the next item the color would change. The problem with that is it will remain changed even when you click the next item, again because you're on the same page without a refresh.

The only thing I can suggest is that you contact Milonic and see if there is some kind of function that could be created to force the issue. Or some way to get them to work without having the page refresh... You can contact them from the main site.

Ruth

Post Reply